AI Actions & Workflow Automations executions are delayed

Incident Report for Contentful

Resolved

AI Actions & Workflow Automations executions have been recovered to normal speed.
Posted Oct 21, 2025 - 13:53 UTC

Monitoring

Our upstream provider has implemented a fix and we are seeing AI Actions and Automations recovery on execution durations. We are monitoring the health of the systems.
Posted Oct 21, 2025 - 13:21 UTC

Identified

Our upstream provider has identified the cause of the issue and working on resolving it at the moment.
Posted Oct 21, 2025 - 12:57 UTC

Investigating

Our monitoring systems have detected an outage of a upstream provider orchestrating jobs that are responsible for executing AI Actions and Workflow Automations. We expect to see delayed execution.
Posted Oct 21, 2025 - 11:01 UTC
This incident affected: Content Management API and Web App.