GraphQL errors - Colliding Type names

Incident Report for Contentful

Resolved

This issue has been resolved.
Posted Jan 27, 2026 - 16:28 UTC

Monitoring

We have deployed a fix which has mitigated the issue for customers. We are continuing to monitor the situation.
Posted Jan 27, 2026 - 16:06 UTC

Investigating

We are investigating an issue where some customers are experiencing errors containing “COLLIDING_TYPE_NAMES” when using Contentful GraphQL API. This is occurring in particular when customers have content types named “Pages”. We are working on a fix for this issue.
Posted Jan 27, 2026 - 15:41 UTC
This incident affected: GraphQL Content API.