Issues when adding to Releases in the Contentful WebApp

Incident Report for Contentful

Resolved

The issue is resolved.
Posted Oct 17, 2025 - 17:25 UTC

Monitoring

We have provided a resolution and will monitor the situation.
Posted Oct 17, 2025 - 17:20 UTC

Investigating

Customers are experiencing issues where entries cannot be added to Releases. We are investigating.
Posted Oct 17, 2025 - 17:16 UTC
This incident affected: Web App and EU data residency (Web App).