Stale entries on Content Delivery API

Incident Report for Contentful

Resolved

We identified the source of the issue which caused some items which were purged to get stuck in cache. We have complete a full cache purge in the EU and the issue is now resolved.
Posted Sep 03, 2026 - 13:25 UTC

Update

We are continuing to investigate this issue impacting a subset of customers in the EU.
Posted Sep 03, 2026 - 09:23 UTC

Investigating

Some customers in the EU data residency region are receiving stale entries from Content Delivery API. We are investigating.
Posted Sep 03, 2026 - 07:45 UTC
This incident affected: EU data residency (Content Delivery API).