Merge App issues for EU Data Residency customers

Incident Report for Contentful

Resolved

We have monitored the fix and confirmed that the issue is resolved.
Posted Jul 23, 2025 - 13:12 UTC

Monitoring

We have put a fix in place and customers should be able to use the Merge app in the EU region again. We apologise for the inconvenience.
Posted Jul 23, 2025 - 12:53 UTC

Investigating

Customers in the EU Data Residency region may be experiencing issues with the Merge App. We are investigating this issue and expect to have a fix in place soon.
Posted Jul 23, 2025 - 11:55 UTC
This incident affected: Web App and EU data residency (Web App).