Optimization hub not rendering

Incident Report for Contentful

Resolved

The issue has been resolved
Posted Mar 13, 2026 - 13:13 UTC

Investigating

We've spotted that something has gone wrong. The Optimization page is not loading. We're currently investigating the issue, and will provide an update soon.
Posted Mar 13, 2026 - 12:41 UTC