Customers unable to access Organisation settings

Incident Report for Contentful

Resolved

We have validated that the fix resolved the issue and customers are no longer seeing errors when accessing the org settings page in the Contentful WebApp.
Posted Mar 31, 2026 - 15:03 UTC

Monitoring

We have identified an issue where customers see an error when trying to access organisation settings in the Contentful WebApp. We have already applied a fix and are verifying the results.
Posted Mar 31, 2026 - 14:58 UTC
This incident affected: Web App.