Issues with full-text search and locale-based publishing for some EU customers

Incident Report for Contentful

Update

We continue working towards full resolution.
Posted Jun 12, 2026 - 15:49 UTC

Identified

A small amount of EU customers might still experience issues related to locale-based publishing. We are working on resolving these.
Posted Jun 12, 2026 - 13:48 UTC

Monitoring

We have resolved the issue for all affected customers and are monitoring.
Posted Jun 12, 2026 - 12:26 UTC

Update

We have resolved the issue for the majority of customers and are continuing working on full resolution.
Posted Jun 12, 2026 - 11:02 UTC

Identified

Some customers in the EU may experience issues finding content via full-text search. We have identified the issue and are working on a resolution.
Posted Jun 12, 2026 - 07:53 UTC
This incident affects: EU data residency (Content Management API).