Increased latency and error rates for Snapshots

Incident Report for Contentful

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 14:14 UTC

Monitoring

We've addressed the issue and are monitoring the situation.
Posted Aug 10, 2026 - 13:55 UTC

Update

Snapshot creation remains impacted. We continue to work on resolving the issue.
Posted Aug 10, 2026 - 12:27 UTC

Identified

Some customers are experiencing increased latency and errors when working with Snapshots. We are working on a resolution.
Posted Aug 10, 2026 - 11:08 UTC
This incident affected: Content Management API and EU data residency (Content Management API).